+7(499)-938-42-58 Москва
+7(800)-333-37-98 Горячая линия

Интерактивные возможности табличного документа. Работа с табличным документом 1с вывести табличный документ

Табличный документ на управляемой форме в 1С 8.3

Интерактивные возможности табличного документа. Работа с табличным документом 1с вывести табличный документ

В  предыдущих статьях, все табличные документы выводились в виде отдельного окна, что, согласитесь, бывает иногда не удобно. В этой статье я покажу, как выводить табличный документ на управляемой форме.

Я рассмотрю два примера. В первом, мы будем на управляемой форме выводить произвольный отчет, который будет сделан при помощи макета табличного документа. А во втором примере, я создам форму для вывода различных печатных форм документов, как это делается в большинстве современных конфигураций.

Пример с отчетом

Реализуем самый простой вариант отчета, который будет без какой-то смысловой нагрузки, призванный просто показать, как работает табличный документ на управляемой форме. В основном все современные отчеты делают на СКД, но этот мы сделаем по «старинке», используя табличный документ. Для этого создадим объект Отчет и подчиненный ему макет табличного документа всего с одной областью.

Подробнее о том, как создается и оформляется макет табличного документа, читайте в этой статье:

Создание и оформление макета табличного документа

Следующим шагом создадим пустую форму подчиненную этом отчёту, и добавим у неё реквизит управляемой формы с типом ТабличныйДокумент.

Поместим этот реквизит на форму. Если его перетащить мышкой, то он станет элементом поля табличного документа. Чтобы не было заголовка, нужно в свойстве ПоложениеЗаголовка добавленного элемента формы установить значение Нет.

Создадим команду управляемой формы, и поместим её на форму в виде кнопки.

Для команды создадим обработчики в серверном и клиентском контексте. В серверном обработчике получим макет табличного документа и единственную область макета. А потом просто будем выводить, как мы это уже делали ранее, полученную область в табличном документе — реквизите формы.

&НаСервере Процедура ПечатьНаСервере() МакетТД = Отчеты.НашОтчет.ПолучитьМакет(“Макет”); ОбластьШапка = МакетТД.ПолучитьОбласть(“Область”); ТабДок.Вывести(ОбластьШапка); КонецПроцедуры &НаКлиенте Процедура Печать(Команда) ПечатьНаСервере(); КонецПроцедуры

Подробнее о заполнении табличных документов читайте в этой статье:

Простой пример заполнения табличного документа

И всё, если мы сейчас попробуем выполнить нашу команду, то отчет заполнится нужными данными.

Пример с печатной формой документа

А сейчас, мы доработаем вывод печатной формы документа, который мы делали в статье ранее:

Создание и вывод печатной формы документа

Раньше у нас печатная форма документа выходила каждый раз в отдельном окне, так её выводила платформа 1С, мы же сделаем так, чтобы печатная форма выводилась в нужной нам управляемой форме.

Для этого мы создадим общую форму, которую назовем ФормаВыводаПечатнойФормы.

У этой формы создадим реквизит с типом ТабличныйДокумент, разместим его на форме, а также поменяем заголовок формы.

Следующим шагом, создадим параметр ТабДок с типом ТабличныйДокумент.

Нам осталось при создании формы реквизиту управляемой формы присвоить значение параметра.

&НаСервере Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) ТабличныйДокументФормы = Параметры.ТабДок; КонецПроцедуры

На этом мы закончим работать с общей формой. В нашем случае, при открытии, форма будет заполняться тем табличным документом, который будет передан в параметре.

Перейдем в модуль команды документа, которую мы создали в предыдущей статье.

Создание печатной формы документа

И подправим эту команду: будем открывать общую форму, в которую в качестве параметра передадим сформированный ранее табличный документ.

&НаСервере Функция ПолучитьТабличныеДокументы(МассивДокументов) Возврат Документы.ПриходТовара.СформироватьПечатныйДокумент(МассивДокументов); КонецФункции &НаКлиенте Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды) ТабличныйДокумент = ПолучитьТабличныеДокументы(ПараметрКоманды); Если ТабличныйДокумент = Неопределено Тогда Возврат КонецЕсли; новФормПараметры = Новый Структура(“ТабДок”,ТабличныйДокумент); ОткрытьФорму(“ОбщаяФорма.ФормаВыводаПечатнойФормы”, новФормПараметры,, Новый УникальныйИдентификатор,,,, РежимОткрытияОкнаФормы.Независимый); КонецПроцедуры

Чтобы каждый раз открывалась новая форма, я передают в качестве третьего параметра новый уникальный идентификатор.

Всё! На этом доработка команды закончена. Можно проверить, как работает открытие нашей формы.

Причем, форму мы можем открыть, как с общего списка документов, так и из нужного нам документа.

Использование расшифровки табличного документа
Расшифровка в табличном документе 1С 8.3

Как использовать расшифровку табличного документа на управляемой форме 1С
Расшифровка в табличном документе на управляемой форме 1С 8.3

Более подробно и основательно разработка в 1С дается в моей книге: «Программировать в 1С за 11 шагов»

Изучайте программирование в 1С в месте с моей книги «Программировать в 1С за 11 шагов»

  1. Книга написана понятным и простым языком — для новичка.
  2. Книга посылается на электронную почту в формате PDF. Можно открыть на любом устройстве!
  3. Научитесь понимать архитектуру 1С;
  4. Станете писать код на языке 1С;
  5. Освоите основные приемы программирования;
  6. Закрепите полученные знания при помощи задачника;

О том как разрабатывать под управляемым приложением 1С, читайте в книге Книга «Основы разработки в 1С: Такси»

Отличное пособие по разработке в управляемом приложении 1С, как для начинающих разработчиков, так и для опытных программистов.

  1. Очень доступный и понятный язык изложения
  2. Книга посылается на электронную почту в формате PDF. Можно открыть на любом устройстве!
  3. Поймете идеологию управляемого приложения 1С
  4. Узнаете, как разрабатывать управляемое приложение;
  5. Научитесь разрабатывать управляемые формы 1С;
  6. Сможете работать с основными и нужными элементами управляемых форм
  7. Программирование под управляемым приложением станет понятным

Промо-код на скидку в 15% — 48PVXHeYu

Вступайте в мои группы:

: https://.com/1c_prosto
Фейсбуке: https://www..com/groups/922972144448119/
ОК: http://ok.ru/group/52970839015518
Твиттер: https://.com/signum2009

1С сохранить табличный документ в excel программно

Интерактивные возможности табличного документа. Работа с табличным документом 1с вывести табличный документ

MS Excel давно стал стандартом для работы с электронными таблицами. В статье рассматриваются способы программной выгрузки и загрузки из 1С в файлы Excel.

Существует несколько способов программной работы с файлами Excel из 1С. Каждый из них имеет свои преимущества и недостатки.

Обмен через табличный документ

Данный способ простой. Его суть заключается в том, что объект ТабличныйДокумент имеет методы:

  • Записать ( ИмяФайла >, ТипФайлаТаблицы >) для выгрузки данных в файл;
  • Прочитать ( ИмяФайла >, СпособЧтенияЗначений >) для загрузки данных из файла.

Внимание!

Метод Записать () доступен как на клиенте, так и на сервере. Метод Прочитать () доступен только на стороне сервера. Необходимо помнить об этом
при планировании клиент-серверного взаимодействия.

Рассмотрим пример сохранения табличного документа в файл. Необходимо любым способом создать и заполнить объект ТабличныйДокумент, а выгрузка в файл осуществляется всего лишь одной строкой:

ТабДок . Записать ( ПутьКФайлу , ТипФайлаТабличногоДокумента . XLSX );

Здесь ТабДок — сформированный табличный документ, ПутьКФайлу — имя файла для выгрузки, ТипФайлаТабличногоДокумента.XLSX — формат создаваемого файла. Поддерживаются следующие форматы Excel:

  • XLS95 — формат Excel 95;
  • XLS97 — формат Excel 97;
  • XLSX — формат Excel 2007.

Загрузка из файла осуществляется также достаточно просто:

ТабДок = Новый ТабличныйДокумент ;
ТабДок . Прочитать ( ПутьКФайлу , СпособЧтенияЗначенийТабличногоДокумента.Значение );

Здесь ПутьКФайлу — путь к загружаемому файлу Excel. СпособЧтенияЗначенийТабличногоДокумента.Значение определяет, каким образом нужно интерпретировать данные, считываемые из исходного документа. Доступны варианты:

Обмен через OLE

Обмен через технологию OLE automation, пожалуй, самый распространенный вариант программной работы с файлами Excel. Он позволяет использовать весь функционал, предоставляемый Excel, но отличается медленной скоростью работы по сравнению с другими способами. Для обмена через OLE требуется установка MS Excel:

  • На компьютере конечного пользователя, если обмен происходит на стороне клиента;
  • На компьютере сервера 1С:Предприятие, если обмен происходит на стороне сервера.

Пример выгрузки:

// Создание COM-объекта Эксель = Новый COMОбъект ( «Excel.Application» ); // Отключение вывода предупреждений и вопросов Эксель . DisplayAlerts = Ложь; // Создание новой книги Книга = Эксель . WorkBooks . Add (); // Позиционирование на первом листе

Лист = Книга . Worksheets ( 1 );

// Запись значения в ячейку
Лист . Cells ( НомерСтроки , НомерКолонки ). Value = ЗначениеЯчейки ;

// Сохранение файла
Книга . SaveAs ( ИмяФайла );

// Закрытие Эксель и освобождение памяти Эксель . Quit ();

Эксель = 0 ;

Примеры чтения:

// Создание COM-объекта Эксель = Новый COMОбъект ( «Excel.Application» ); // Открытие книги Книга = Эксель . Workbooks . Open ( ПутьКФайлу ); // Позиционирование на нужном листе

Лист = Книга . Worksheets ( 1 );

// Чтение значения ячейки, обычно здесь располагается цикл обхода ячеек
ЗначениеЯчейки = Лист . Cells ( НомерСтроки , НомерКолонки ). Value ;

// Закрытие книги
Книга . Close ( 0 );

// Закрытие Эксель и освобождение памяти Эксель . Quit ();

Эксель = 0 ;

// Открытие книги Книга = ПолучитьCOMОбъект ( ПутьКФайлу ); // Позиционирование на нужном листе

Лист = Книга . Worksheets ( 1 );

// Чтение значения ячейки, обычно здесь располагается цикл обхода ячеек
ЗначениеЯчейки = Лист . Cells ( НомерСтроки , НомерКолонки ). Value ;

// Закрытие книги
Книга . Application . Qui t ();

Для обхода всех заполненных строк листа Excel можно использовать следующие приемы:

// —— ВАРИАНТ 1 —— КоличествоСтрок = Лист . Cells ( 1 , 1 ). SpecialCells ( 11 ). Row ; Для НомерСтроки = 1 По КоличествоСтрок Цикл ЗначениеЯчейки = Лист . Cells ( НомерСтроки , НомерКолонки ). Value ;

КонецЦикла;

// —— ВАРИАНТ 2 —— НомерСтроки = 0 ; Пока Истина Цикл НомерСтроки = НомерСтроки + 1 ; ЗначениеЯчейки = Лист . Cells ( НомерСтроки , НомерКолонки ). Value ; Если НЕ ЗначениеЗаполнено ( ЗначениеЯчейки ) Тогда Прервать; КонецЕсли;

КонецЦикла;

Вместо последовательного обхода всех строк листа можно выгрузить все данные в массив и работать с ним. Такой подход будет быстрее при чтении большого объема данных:

ВсегоКолонок = Лист . Cells ( 1 , 1 ). SpecialCells ( 11 ). Column ;
ВсегоСтрок = Лист . Cells ( 1 , 1 ). SpecialCells ( 11 ). Row ;

Область = Лист . Range ( Лист . Cells ( 1 , 1 ), Лист . Cells ( ВсегоСтрок , ВсегоКолонок ));
Данные = Область . Value . Выгрузить ();

Многостраничный Excel из 1С

Интерактивные возможности табличного документа. Работа с табличным документом 1с вывести табличный документ

В последнее время мне очень часто приходится работать с таблицами Excel из 1С. Это первая статья, посвященная работе с Excel из 1С и в ней я покажу как сохранять несколько табличный документов в одном, многостраничном файле Excel.

С помощью объекта пакетотображаемыхдокументов

Начиная с версии 8.3.3 платформы 1С реализован объект ПакетОтображаемыхДокументов, через который и реализована печать во всех современных типовых конфигурациях. С помощью этого объекта очень легко сформировать многостраничную книгу Excel, т.е. каждый табличный документ выводится на своем листе.

// Сохраняет табличные документы в файл Эксель // // Параметры: // ИмяФайла – Строка – указывающая имя сохраняемого файла. // Можно включить полный путь; // // МассивДанных – Массив – массив соответствий: // * ДанныеЛиста – соответствие: // ** АдресВХранилище – адрес табличного документа во временном хранилище // ** Имя – имя листа. // &НаКлиенте Процедура СформироватьФайлПакетом(ИмяФайла, МассивДанных) Пакет = Новый ПакетОтображаемыхДокументов; Для каждого ДанныеЛиста Из МассивДанных Цикл АдресВХранилище = ДанныеЛиста[“АдресВХранилище”]; ЭлементПакета = Пакет.Состав.Добавить(); ЭлементПакета.Наименование = ДанныеЛиста[“Имя”]; ЭлементПакета.Данные = АдресВХранилище; КонецЦикла; Попытка Пакет.Записать(ИмяФайла, ТипФайлаПакетаОтображаемыхДокументов.XLSX); ПоказатьПредупреждение(, “Файл выгружен в ” + ИмяФайла); Исключение ПоказатьПредупреждение(,”Ошибка выгрузки в ” + ИмяФайла); Сообщить(ОписаниеОшибки()); КонецПопытки; КонецПроцедуры // СформироватьФайлПакетом()

// Сохраняет табличные документы в файл Эксель//  ИмяФайла  – Строка – указывающая имя сохраняемого файла.// Можно включить полный путь;//                 //  МассивДанных  – Массив – массив соответствий:// * ДанныеЛиста – соответствие:// ** АдресВХранилище – адрес табличного документа во временном хранилищеПроцедура СформироватьФайлПакетом(ИмяФайла, МассивДанных) Пакет = Новый ПакетОтображаемыхДокументов; Для каждого ДанныеЛиста Из МассивДанных Цикл АдресВХранилище = ДанныеЛиста[“АдресВХранилище”]; ЭлементПакета = Пакет.Состав.Добавить(); ЭлементПакета.Наименование = ДанныеЛиста[“Имя”]; ЭлементПакета.Данные = АдресВХранилище; Пакет.Записать(ИмяФайла, ТипФайлаПакетаОтображаемыхДокументов.XLSX);     ПоказатьПредупреждение(, “Файл выгружен в ” + ИмяФайла); ПоказатьПредупреждение(,”Ошибка выгрузки в ” + ИмяФайла); Сообщить(ОписаниеОшибки());КонецПроцедуры // СформироватьФайлПакетом()

ИмяФайла — имя файла в который будет сохранена книга. Можно перед вызовом функции предлагать пользователю указать каталог, куда будет сохраняться файл, и в параметр передать полный путь до файла, например «D:\Файлы\МойФайлЭксель.xlsx».

МассивДанных — массив соответствий с данными для формирования книги. Массив собираю на сервере. Соответствие представляет из себя коллекцию значений в связки с ключем. Ключи — Имя (имя листа в книге) и АдресВХранилище (адрес табличного документа во временном хранилище).

В отличие от второго варианта файл сохраняется значительно быстрее.

С помощью com-объекта excel.application

Этот вариант подойдет тем, кому приходится работать со старыми версиями платформы. 1С позволяет сохранять табличный документ в эксель:

ТабличныйДокумента.Записать(, );

ТабличныйДокумента.Записать(, );

Указав в качестве типа файла таблицы ТипФайлаТабличногоДокумента.XLSX в итоге получим файл Эксель, но в нем мы не увидим привычных листов, соответственно и сохранить несколько табличных документов в одну книгу не получится.

В результате изучения проблемы и поисков в интернете, родился следующий алгоритм, который был реализован в качестве процедуры:

  1. Открываем Эксель;
  2. Создаем новую книгу с 1 листом (переменная Книга);
  3. В цикле каждое табличный документ сохраняем в файл с типом xlsx;
  4. Открываем файл с выгруженным табличным документом, и копируем лист в нашу рабочую книгу, вставляя последним листом;
  5. Закрываем временный файл, удаляем из временного хранилища и переходим к следующему табличному документу;
  6. Последним шагом — сохраняем книгу, закрываем эксель.

&НаКлиенте Процедура СформироватьФайл(ИмяФайла, МассивДанных) ОбъектЭксель = ПолучитьCOMОбъект(“”, “Excel.Application”); ОбъектЭксель.SheetsInNewWorkbook = 1; // в новой книге создавать только 1 лист ОбъектЭксель.DisplayAlerts = False; Книга = ОбъектЭксель.Workbooks.Add(); Попытка НомерЛиста = 1; Для каждого ДанныеЛиста Из МассивДанных Цикл АдресВХранилище = ДанныеЛиста[“АдресВХранилище”]; ТабличныйДокумента = ПолучитьИзВременногоХранилища(АдресВХранилище); ИмяВременногоФайла = ПолучитьИмяВременногоФайла(“xlsx”); ТабличныйДокумента.Записать(ИмяВременногоФайла, ТипФайлаТабличногоДокумента.XLSX); ВременнаяКнига = ОбъектЭксель.Workbooks.Open(ИмяВременногоФайла); ЛистИсточник = ВременнаяКнига.WorkSheets(1); ЛистИсточник.Copy(Книга.WorkSheets(НомерЛиста)); Книга.WorkSheets(НомерЛиста).Name = ДанныеЛиста[“Имя”]; ВременнаяКнига.Close(0); УдалитьИзВременногоХранилища(АдресВХранилище); НомерЛиста = НомерЛиста + 1; КонецЦикла; Книга.Sheets(НомерЛиста).Delete(); ОбъектЭксель.Workbooks(1).Activate(); Книга.Worksheets(1).Activate(); Книга.SaveAs(ИмяФайла); Книга.Close(0); ОбъектЭксель.Quit(); ОбъектЭксель = Неопределено; ПоказатьПредупреждение(,”Файл выгружен в ” + ИмяФайла); Исключение ПоказатьПредупреждение(,”Ошибка выгрузки в ” + ИмяФайла); Сообщить(ОписаниеОшибки()); Если ОбъектЭксель Неопределено Тогда ОбъектЭксель.Quit(); ОбъектЭксель = Неопределено; КонецЕсли; КонецПопытки; КонецПроцедуры // СформироватьФайл()

Процедура СформироватьФайл(ИмяФайла, МассивДанных) ОбъектЭксель = ПолучитьCOMОбъект(“”, “Excel.Application”); ОбъектЭксель.SheetsInNewWorkbook = 1; // в новой книге создавать только 1 лист ОбъектЭксель.DisplayAlerts = False;        Книга = ОбъектЭксель.Workbooks.Add(); Для каждого ДанныеЛиста Из МассивДанных Цикл АдресВХранилище = ДанныеЛиста[“АдресВХранилище”]; ТабличныйДокумента = ПолучитьИзВременногоХранилища(АдресВХранилище); ИмяВременногоФайла = ПолучитьИмяВременногоФайла(“xlsx”);             ТабличныйДокумента.Записать(ИмяВременногоФайла, ТипФайлаТабличногоДокумента.XLSX); ВременнаяКнига = ОбъектЭксель.Workbooks.Open(ИмяВременногоФайла); ЛистИсточник = ВременнаяКнига.WorkSheets(1); ЛистИсточник.Copy(Книга.WorkSheets(НомерЛиста)); Книга.WorkSheets(НомерЛиста).Name = ДанныеЛиста[“Имя”]; УдалитьИзВременногоХранилища(АдресВХранилище); НомерЛиста = НомерЛиста + 1; Книга.Sheets(НомерЛиста).Delete(); ОбъектЭксель.Workbooks(1).Activate(); Книга.Worksheets(1).Activate(); ОбъектЭксель = Неопределено; ПоказатьПредупреждение(,”Файл выгружен в ” + ИмяФайла); ПоказатьПредупреждение(,”Ошибка выгрузки в ” + ИмяФайла); Сообщить(ОписаниеОшибки()); Если ОбъектЭксель Неопределено Тогда ОбъектЭксель = Неопределено;КонецПроцедуры // СформироватьФайл()

Работа с расшифровкой в табличном документе

Интерактивные возможности табличного документа. Работа с табличным документом 1с вывести табличный документ

Методические рекомендации

Табличный документ предоставляет пользователю возможность работы с расшифровкой – детализацией информации, располагающейся в ячейке документа. В данной статье описываются некоторые особенности механизма расшифровок табличного документа.

Для чего используется расшифровка и как ей пользоваться

Основное назначение расшифровки – получение дополнительной информации об объекте, отображенном в табличном документе. Например, пользователь выбрал ячейку отчета, содержащую название контрагента.

По двойному щелчку левой кнопки мыши может быть открыт диалог, содержащий дополнительную информацию о данном контрагенте.

Например, может быть запущен новый отчет по всем документам данного контрагента, или открыто контекстное меню, в котором пользователю выдаются возможные варианты расшифровки и т.д.

Для того чтобы воспользоваться расшифровкой, пользователю необходимо навести курсор мыши на нужную ячейку. Если для данной ячейки существует расшифровка, то при этом должен измениться вид курсора.

Расшифровка может быть вызвана при помощи двойного щелчка левой кнопкой мыши, либо при помощи клавиши Enter.

Дальнейшее действие по обработке расшифровки будет зависеть от того, какая расшифровка была предусмотрена в программе.

Получение расшифровки возможно только в том случае, если табличный документ находится в режиме “Только просмотр” или в режиме защиты. В остальных случаях при двойном щелчке мыши табличный документ будет переходить в режим редактирования содержимого ячейки.

Заполнение расшифровки

Расшифровка представляет собой значение, которое присвоено свойству “Расшифровка” области ячеек табличного документа или рисунку табличного документа. Заполнить данное свойство можно одним из следующих способов:

1. Непосредственно присвоив данному свойству значение.

Этот способ может быть удобным в том случае, если табличный документ заполняется при помощи встроенного языка без использования макета и построителя отчета.

Пример:

ЭлементыФормы.ПолеТабличногоДокумента1.Область(1,1).Расшифровка = “Текст расшифровки”;

В данном примере расшифровка устанавливается первой ячейке первой строки поля табличного документа.

2. Использовать параметр расшифровки и метод “Вывести”.

Часто табличный документ заполняется при помощи макета и метода табличного документа “Вывести”. В таком случае в ячейке макета можно указать свойство “Параметр расшифровки”. При вызове метода “Вывести”, этот параметр будет использован для заполнения значения свойства расшифровки.

Обработка расшифровки

После того, как расшифровка заполнена, следует позаботиться об ее обработке.

 Если табличный документ открыт в отдельном окне, никаких действий по обработке расшифровки выполнить нельзя. В этом случае расшифровка будет работать в соответствии со своим поведением по умолчанию – то есть, будет открыто значение расшифровки. Для ссылочных типов будет открыта основная форма объекта, для других типов будет отображена строка, представляющая значение расшифровки.

Если табличный документ отображается в поле табличного документа, возможно переопределение поведения расшифровки. Для этого нужно создать обработчик события ОбработкаРасшифровки поля табличного документа.

Это событие будет вызываться при каждой попытке пользователя вызвать расшифровку. В обработчик события будет передано поле табличного документа, для которого вызвана расшифровка, значение расшифровки и флаг стандартной обработки расшифровки.

Если стандартная обработка расшифровки не нужна, следует присвоить флагу СтандартнаяОбработка значение “Ложь”.

1с вывести табличный документ. Интерактивные возможности табличного документа

Интерактивные возможности табличного документа. Работа с табличным документом 1с вывести табличный документ

Табличный документ используется для создания первичных документов и отчетов, которые состоят из ячеек организованных в строки и колонки. У каждой строки и колонки есть свой уникальный номер. При этом отдельным ячейкам, диапазонам и графическим объектам можно присвоить имя выделив нужную область используя раздел “Таблица – Имена”. После введем имя в поле ввода и нажмем “Присвоить”.

Для того, чтобы удалить имя выберем его из списка и нажмем на кнопку “Удалить”. Тем областям, которым пользователь не присвоил имя, программа даст название автоматически. Эти имена можно увидеть в палитре свойств.Табличный редактор может использоваться для создания нового документа, просмотра результатов прежних отчётов и редактирования документов табличного типа.

Как в 1С создать табличный документ

Для создания нового документа необходимо нажать на раздел “Файл” – “Новый”, после чего выбрать строку “Табличный документ” и подтвердить кнопкой “ОК”.Если нужно открыть уже созданный документ, тогда в разделе “Файл” – “Открыть” выбираем в списке имя файла необходимого документа. При этом можно выбрать любой формат открываемого документа нажав на поле “Тип файла”.

При создании таблицы выделим ячейку и введем данные (текст, формула, численные данные). Если необходимо изменить размер ячеек, тогда в Меню выберем “Формат – Строка – Автоподбор высоты – Столбец – Автоподбор ширины”.

Для этого наведем мышку на границу заголовка строки или столбца, удерживая левую кнопку мыши, протяжкой изменим размер. Видоизменится в 1С высота строки табличного документа и ширина столбца.

Команда автоподбора открывается двойным кликом на границу заголовка.

Вы можете смело повторять все действия у себя в базе или с легкостью создать табличный документ в 1С:Готовые решения – облачной версии лицензионной программы 1С. Тестируйте сервис бесплатно в течение 14 дней в 1С Онлайн .

Как изменить в 1С высоту строки и ширину колонок

Размер строк и столбцов табличного документа можно изменить вручную или автоматически.

В программе 1С высота строки табличного документа изменится вручную, если навести мышку на нижнюю границу заголовка строки и дождаться когда курсор мыши преобразуется в раздвоенную вертикальную стрелку. После этого устанавливаем необходимую нам высоту строки перемещая границы заголовка.

Изменить ширину столбца можно, если установить указатель мыши на правую границу заголовка и дождаться когда курсор мыши преобразуется в раздвоенную горизонтальную стрелку. Переместив мышью границу заголовка, установим необходимую ширину.

Минимально необходимую ширину столбца можно установить с помощью двух щелчков мыши на границу заголовка. Редактор самостоятельно установит ту ширину, в которую полностью помещается текст.

Существует еще один способ ручного изменения. Нажмите на клавишу “Ctrl” и наведите мышку на нужную границу ячейки. После того как форма курсора изменится – установите нужный размер.

В 1С ширина колонки табличного документа изменится автоматически, если выделить необходимый столбец и выбрать раздел “Таблица” – “Ячейки” – “Ширина колонок”. В появившемся окне указать ширину и нажать “ОК”.

Создавая новый табличный документ ширина всех столбцов устанавливается по умолчанию. Но ее также можно изменить. Для этого в “Таблице” выбрать “Ячейка” – “Ширина колонок”. В появившемся окне задать размер колонки и нажать “ОК”. Если выбрать “Авто”, тогда размер устанавливается на весь документ.

Автоматически изменится высота строки, если установить флажок “Автовысота строки”. Если флажок не установить, тогда в поле “Высота строк” задаётся фиксированный размер строки.

Для того, чтобы установить различную ширину колонок для различных строк, необходимо выделить одну или несколько строк документа.

Подведем мышкой к разделителю колонок и нажмем левую кнопку мыши. Не отпуская кнопку потянем столбец в нужную сторону (к примеру, влево) и отпустим кнопку. В появившемся окне нажмем на “ОК”.

Также можно управлять цветом текста, фона и рамок.

Как правило, табличный документ формируется на основе макета, который представляет собой шаблон для формирования печатной формы. В сам макет можно включить рисунки, диаграммы, а также сводные таблицы. На примере изображен макет для печати расходной накладной:

В одних ячейках содержится только текст, в других – имена параметров, которые необходимо указать в программном модуле через “Параметры” объекты “Табличный документ”.

Группировка строк в табличном документе

В табличном документе есть возможность группировать строки и столбцы для того, чтобы классифицировать данные в отчетах. Существуют горизонтальные группировки, которые могут быть расположены справа или слева, и вертикальные размещенные сверху или снизу.

Также можно отобразить уровни группировки. При нажатии цифр в заголовке разворачиваются сразу все группировки. При применении группировки отступ уровней формируется автоматически:

Расшифровка табличного документа 1C

Воспользуемся механизмом расшифровки, чтобы получить детальный или дополнительный отчёт. Для этого нажимаем мышкой на строку или ячейку документа.

Существует два действия при расшифровке документа:

  • Стандартные – нажимаем мышкой на документ или элемент справочника, после чего система откроет этот объект для просмотра.
  • Нестандартные – зададим алгоритм получения детального отчета. Для этого необходимо переформировать существующий с использованием дополнительных условий отбора (“показать продажи только по этому контрагенту”). Или же,

При использовании расшифровки можно получить совершенно новый отчёт (например “показать расходные накладные, которые сделали вклад в объем продаж по данному контрагенту”).

Так как вызов отчетов, содержащихся в конкретном прикладном решении, совершается автоматически – это усложняет работу пользователя. Для того, чтобы облегчить работу и нужен механизм расшифровок.

Как в 1С сохранить табличный документ

Для того, чтобы в дальнейшем можно было пользоваться табличным документом (открывать, просматривать, распечатывать) – необходимо его сохранить. Выберем раздел “Файл” и нажмем “Сохранить”. После этого на экране появится окно, в котором укажем каталог и имя файла. Если необходимо переименовать документ, либо сохранить его в другом формате – выберем раздел “Файл” и “Сохранить как”.

Как правило, документ сохраняется в том формате, которую использует система “1С:Предприятие” (*.mxl).

При этом табличный документ может быть экспортирован в другие форматы хранения данных,в том числе в формат электронной таблицы ODF (*.ods), документ Word (*.docx), документ HTML (*.

htm) или в текстовый файл UNICODE (*.txt). Вдобавок имеется возможность сохранить в 1С табличный документ в excel или в pdf.

Печать табличного документа в 1С

Для просмотра документ перед печатью, выберем раздел “Файл – Предварительный просмотр”. Для того, чтобы выйти из предварительного просмотра нажмем кнопку “Закрыть”.

В настройках страницы установим в 1С параметры печати табличного документа – масштаб, размер, границы и т.д. В табличном редакторе установим параметры размещения строк и столбцов. В “Положение на странице” принудительно установлено разбиение на страницы, повторение строк и столбцов и т.д.

Выведем документ на принтер нажав на раздел “Файл” – “Печать”. На странице появится окно с настройками, где нужно установить параметры печати – выбрать принтер, диапазон страниц и кол-во копий – и нажать “ОК”.

Поделиться:
Нет комментариев

    Добавить комментарий

    Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.